// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^\/t(?:\/(\d+)\/[a-z_-]+\/?|op(\d+)\.html)$").unwrap();
let string = "good examples:
/t/2/title/
/t/98127/welcome_world-here/
/top1.html
/top2126.html
/top102542/120939.html
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}