# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{8})(?!$)/$1,/g;t' <<< "123456781234567812345678122"