const regex = /(\d{8})(?!$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{8})(?!$)', 'g')
const str = `123456781234567812345678122`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);