import Foundation
let pattern = #"(\d{8})(?!$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123456781234567812345678122"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)