$re = '/(\d{8})(?!$)/';
$str = '123456781234567812345678122';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;