use strict;
my $str = '123456781234567812345678122';
my $regex = qr/(\d{8})(?!$)/p;
my $subst = '$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";