#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Procedure:([\S\s]+)CLINICAL DIAGNOSIS"
Local $sString = "SPECIMEN: Procedure: xxxx1 A) Location: yyyy2" & @CRLF & _
"Major zzz B) Location: something" & @CRLF & _
"text here C) more" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLINICAL DIAGNOSIS: xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")