package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Procedure:([\S\s]+)CLINICAL DIAGNOSIS`)
var str = `SPECIMEN: Procedure: xxxx1 A) Location: yyyy2
Major zzz B) Location: something
text here C) more
CLINICAL DIAGNOSIS: xyz`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}