using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Procedure:([\S\s]+)CLINICAL DIAGNOSIS";
string input = @"SPECIMEN: Procedure: xxxx1 A) Location: yyyy2
Major zzz B) Location: something
text here C) more
CLINICAL DIAGNOSIS: xyz";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}