re = /Procedure:([\S\s]+)CLINICAL DIAGNOSIS/
str = 'SPECIMEN: Procedure: xxxx1 A) Location: yyyy2
Major zzz B) Location: something
text here C) more
CLINICAL DIAGNOSIS: xyz'
# Print the match result
str.match(re) do |match|
puts match.to_s
end