import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Procedure:([\\S\\s]+)CLINICAL DIAGNOSIS";
final String string = "SPECIMEN: Procedure: xxxx1 A) Location: yyyy2\n"
+ "Major zzz B) Location: something\n"
+ "text here C) more\n\n\n"
+ "CLINICAL DIAGNOSIS: xyz";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}