#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((/[a-zA-Z0-9-_]+)+|/)$"
Local $sString = "valid" & @CRLF & _
"/abc/def" & @CRLF & _
"/hello_123/world-456" & @CRLF & _
"/three/directories/yay" & @CRLF & _
"/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"invalid" & @CRLF & _
"/abc/def/" & @CRLF & _
"/abc//def" & @CRLF & _
"//" & @CRLF & _
"abc/def" & @CRLF & _
"/abc/def/file.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")