const regex = new RegExp('^((/[a-zA-Z0-9-_]+)+|/)$', 'gm')
const str = `valid
/abc/def
/hello_123/world-456
/three/directories/yay
/
invalid
/abc/def/
/abc//def
//
abc/def
/abc/def/file.txt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}