re = /^((\/[a-zA-Z0-9-_]+)+|\/)$/m
str = 'valid
/abc/def
/hello_123/world-456
/three/directories/yay
/
invalid
/abc/def/
/abc//def
//
abc/def
/abc/def/file.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end