$re = '`^((/[a-zA-Z0-9-_]+)+|/)$`m';
$str = 'valid
/abc/def
/hello_123/world-456
/three/directories/yay
/
invalid
/abc/def/
/abc//def
//
abc/def
/abc/def/file.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);