package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((/[a-zA-Z0-9-_]+)+|/)$`)
var str = `valid
/abc/def
/hello_123/world-456
/three/directories/yay
/
invalid
/abc/def/
/abc//def
//
abc/def
/abc/def/file.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}