using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((/[a-zA-Z0-9-_]+)+|/)$";
string input = @"valid
/abc/def
/hello_123/world-456
/three/directories/yay
/
invalid
/abc/def/
/abc//def
//
abc/def
/abc/def/file.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}