re = /\/_([a-z]+\/)/
str = '/__ticket/show/xxx
/_ticket/show/xxx
/ticket/ticket/show/xxx'
subst = '/\\1\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result