// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/_([a-z]+\/)").unwrap();
let string = "/__ticket/show/xxx
/_ticket/show/xxx
/ticket/ticket/show/xxx";
let substitution = "/\\1\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}