$re = '/(?:[^»]+?»){3}\s*(.+?)\s*[\nÂ]/m';
$str = 'I need to extract the following text string using google/re2: Audiences » Affinity Categories » Food & Dining » Fast Food Cravers
Audiences » Affinity Categories » Food & Dining » Foodies Audiences » Affinity Categories » Home & Garden
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);