import Foundation
let pattern = #"(?:[^»]+?»){3}\s*(.+?)\s*[\nÂ]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I need to extract the following text string using google/re2: Audiences » Affinity Categories » Food & Dining » Fast Food Cravers
Audiences » Affinity Categories » Food & Dining » Foodies Audiences » Affinity Categories » Home & Garden
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)