import re
regex = re.compile(r"(?:[^»]+?»){3}\s*(.+?)\s*[\nÂ]", flags=re.MULTILINE)
test_str = ("I need to extract the following text string using google/re2: Audiences » Affinity Categories » Food & Dining » Fast Food Cravers\n\n"
"Audiences » Affinity Categories » Food & Dining » Foodies Audiences » Affinity Categories » Home & Garden\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")