re = /(?:[^»]+?»){3}\s*(.+?)\s*[\nÂ]/m
str = 'I need to extract the following text string using google/re2: Audiences » Affinity Categories » Food & Dining » Fast Food Cravers
Audiences » Affinity Categories » Food & Dining » Foodies Audiences » Affinity Categories » Home & Garden
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end