#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc"
Local $sString = "hello123abc ==> no match" & @CRLF & _
"" & @CRLF & _
"helloa123abc ==> no match" & @CRLF & _
"" & @CRLF & _
"hello123aabc ==> no match" & @CRLF & _
"" & @CRLF & _
"hello1abc ==> match helloa123abc " & @CRLF & _
"" & @CRLF & _
"hello23abc ==> match helloa123abc " & @CRLF & _
"" & @CRLF & _
"helloaabc ==> match helloa123abc "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")