re = /(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc/m
str = 'hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match helloa123abc
hello23abc ==> match helloa123abc
helloaabc ==> match helloa123abc '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end