const regex = /(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc', 'gm')
const str = `hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match helloa123abc
hello23abc ==> match helloa123abc
helloaabc ==> match helloa123abc `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}