import Foundation
let pattern = #"(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match helloa123abc
hello23abc ==> match helloa123abc
helloaabc ==> match helloa123abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)