// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc").unwrap();
let string = "hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match helloa123abc
hello23abc ==> match helloa123abc
helloaabc ==> match helloa123abc ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}