package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc`)
var str = `hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match helloa123abc
hello23abc ==> match helloa123abc
helloaabc ==> match helloa123abc `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}