#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+$"
Local $sString = "Q23AS9D0APQQ2" & @CRLF & _
"111111" & @CRLF & _
"aaaaaa" & @CRLF & _
"q2IasK231@!@!#_+123" & @CRLF & _
"asdas12312...1231@asda___213-1" & @CRLF & _
"asdas123121231asda2131"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")