import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?\\d)(?=.*?[a-zA-Z])[a-zA-Z\\d]+$";
final String string = "Q23AS9D0APQQ2\n"
+ "111111\n"
+ "aaaaaa\n"
+ "q2IasK231@!@!#_+123\n"
+ "asdas12312...1231@asda___213-1\n"
+ "asdas123121231asda2131";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}