use strict;
my $str = 'Q23AS9D0APQQ2
111111
aaaaaa
q2IasK231@!@!#_+123
asdas12312...1231@asda___213-1
asdas123121231asda2131';
my $regex = qr/^(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}