const regex = /^(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?\\d)(?=.*?[a-zA-Z])[a-zA-Z\\d]+$', 'gm')
const str = `Q23AS9D0APQQ2
111111
aaaaaa
q2IasK231@!@!#_+123
asdas12312...1231@asda___213-1
asdas123121231asda2131`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}