using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+$";
string input = @"Q23AS9D0APQQ2
111111
aaaaaa
q2IasK231@!@!#_+123
asdas12312...1231@asda___213-1
asdas123121231asda2131";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}