$re = '/^(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+$/m';
$str = 'Q23AS9D0APQQ2
111111
aaaaaa
q2IasK231@!@!#_+123
asdas12312...1231@asda___213-1
asdas123121231asda2131';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);