# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[pullquote\])(.+)(\[\\/pullquote\])/$2/g;t' <<< "[pullquote]Something[/pullquote]
[pullquote]Something else.[/pullquote]"