const regex = /(\[pullquote\])(.+)(\[\/pullquote\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[pullquote\\])(.+)(\\[\\\/pullquote\\])', 'g')
const str = `[pullquote]Something[/pullquote]
[pullquote]Something else.[/pullquote]`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);