$re = '/(\[pullquote\])(.+)(\[\/pullquote\])/';
$str = '[pullquote]Something[/pullquote]
[pullquote]Something else.[/pullquote]';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;