import Foundation
let pattern = #"(\[pullquote\])(.+)(\[\/pullquote\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[pullquote]Something[/pullquote]
[pullquote]Something else.[/pullquote]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)