using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[pullquote\])(.+)(\[\/pullquote\])";
string substitution = @"$2";
string input = @"[pullquote]Something[/pullquote]
[pullquote]Something else.[/pullquote]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}