#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<=\D)|\s*\b)0{4}\d*"
Local $sString = "ANOA 250g 00004689" & @CRLF & _
"ANOA 10000g 00000059884" & @CRLF & _
"80%c asjw 150000001568 " & @CRLF & _
"Shivangi000000478761"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)