use strict;
my $str = 'ANOA 250g 00004689
ANOA 10000g 00000059884
80%c asjw 150000001568
Shivangi000000478761';
my $regex = qr/(?:(?<=\D)|\s*\b)0{4}\d*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";