import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=\\D)|\\s*\\b)0{4}\\d*";
final String string = "ANOA 250g 00004689\n"
+ "ANOA 10000g 00000059884\n"
+ "80%c asjw 150000001568 \n"
+ "Shivangi000000478761";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}