import re
regex = re.compile(r"(?:(?<=\D)|\s*\b)0{4}\d*", flags=re.MULTILINE)
test_str = ("ANOA 250g 00004689\n"
"ANOA 10000g 00000059884\n"
"80%c asjw 150000001568 \n"
"Shivangi000000478761")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)