re = /(?:(?<=\D)|\s*\b)0{4}\d*/m
str = 'ANOA 250g 00004689
ANOA 10000g 00000059884
80%c asjw 150000001568
Shivangi000000478761'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result