const regex = new RegExp('(?:(?<=\\D)|\\s*\\b)0{4}\\d*', 'gm')
const str = `ANOA 250g 00004689
ANOA 10000g 00000059884
80%c asjw 150000001568
Shivangi000000478761`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);