#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[^.\n]+\.[a-z]{2,63}$"
Local $sString = "EXAMPLE.COM" & @CRLF & _
"EXAMPLE.ORG." & @CRLF & _
"EXAMPLE.ORG>." & @CRLF & _
"EXAMPLE.COM"" & @CRLF & _
"EXAMPLE.COM"." & @CRLF & _
"EXAMPLE.COM)." & @CRLF & _
"EXAMPLE.COM(COMMENT)"" & @CRLF & _
"DEPT.EXAMPLE.COM" & @CRLF & _
"EXAMPLE.ORG" & @CRLF & _
"EXAMPLE.COM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")