re = /^[^.\n]+\.[a-z]{2,63}$/im
str = 'EXAMPLE.COM
EXAMPLE.ORG.
EXAMPLE.ORG>.
EXAMPLE.COM"
EXAMPLE.COM".
EXAMPLE.COM).
EXAMPLE.COM(COMMENT)"
DEPT.EXAMPLE.COM
EXAMPLE.ORG
EXAMPLE.COM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end