import re
regex = re.compile(r"^[^.\n]+\.[a-z]{2,63}$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("EXAMPLE.COM\n"
"EXAMPLE.ORG.\n"
"EXAMPLE.ORG>.\n"
"EXAMPLE.COM\"\n"
"EXAMPLE.COM\".\n"
"EXAMPLE.COM).\n"
"EXAMPLE.COM(COMMENT)\"\n"
"DEPT.EXAMPLE.COM\n"
"EXAMPLE.ORG\n"
"EXAMPLE.COM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")