// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[^.\n]+\.[a-z]{2,63}$").unwrap();
let string = "EXAMPLE.COM
EXAMPLE.ORG.
EXAMPLE.ORG>.
EXAMPLE.COM\"
EXAMPLE.COM\".
EXAMPLE.COM).
EXAMPLE.COM(COMMENT)\"
DEPT.EXAMPLE.COM
EXAMPLE.ORG
EXAMPLE.COM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}